Войти
ПрограммированиеФорумГрафика

Проблемы с gl_FragDepth (решено) (3 стр)

Страницы: 1 2 3
#30
11:54, 28 сен 2018

Блин, я тупой! :(
Там же экспонента. Для него даже 0.9 - это близко. В линейном заметно только с 0.9999
Почему в прошлый раз
>gl_FragDepth = gl_FragCoord.z
не отработала как надо - хз. Может сохранить забыл. :(

>У тебя же #version 130, оно только для OpenGL 3.0. Исправляй на #version 120.
А вот тут непонятно. Дрова говорят, что максимальная версия 1.2, но ошибку выдаёт только на 1.4 и какие-то плюшки из 1.3 работали (не помню уже, нафига он был такой)

Ага, как минимум in & out не работают в 1.2

#31
12:11, 28 сен 2018

Grobozavr
> но ошибку выдаёт только на 1.4 и какие-то плюшки из 1.3 работали
Это рано или поздно приведёт к неприятностям.

Тем более на Интеле.

#32
12:32, 28 сен 2018

Если контекст запрашивается 2.1, то приведет. Если нет - то проблема пользователя старой видеокарты.

Страницы: 1 2 3
ПрограммированиеФорумГрафика

Тема в архиве.