Войти
IrrlichtФорум

Помогите откомпилить irrlicht под linux (не ubuntu!!!)

#0
22:33, 20 мая 2010

Привет всем. Есть такая "замечательная" ОС наших вооруженных сил МСВС 3.0 основанная на red hat 6 linux (ядро 2.4.32). Стала проблема откомпилить irrlicht под эту ОС. В инете есть примеры как это сделать в ubuntu. Попробовал и все получается. Вопрос как же это сделать в МСВС? Есть предложения? Какие нужно дополнительно библиотеки установить?

#1
11:05, 21 мая 2010

Я компилировал старенький Irrlicht (вроде 1.5) под Slackware Linux. В этой ОС никаких дополнительных библиотек не потребовалось, но мне не удалось собрать движок в x64 версии. Плюс немного пришлось подправить исходники. Там были проблемы с приведением типов, то это сразу было видно по отчёту gcc.
Я в МСВС не видел, поэтому не знаю каких библиотек там не хватает, но всё же..

Irrlicht требует zlib, jpeglib, libpng. Эти библиотеки также содержатся в исходниках движка, поэтому можно скомпилировать используя как внешние .so, так и интегрированные.
Кроме того, irrlicht требует GL и Xxf86vm.
Эти библиотеки должны лежать в /usr/X11R6/lib (или в /usr/X11R6/lib64 для x64 версии).

#2
13:16, 15 июня 2010

MegaGarynych
запусти команду make  в каталоге исходников и посмотри, на что он ругаться будет. Ключевые моменты здесь покажи. Будет видно чего не хватает.

Под ArchLinux сборка никаких проблем тоже не вызывала: make и подождать некоторое время :)

#3
8:34, 18 июня 2010

Всем спасибо, все получилось. Основная проблема была в том что исходники шли в windows кодировке, точнее LineEndы были виндовсячи поэтому многострочные дефайны не правильно компилились.

IrrlichtФорум

Тема в архиве.